Connection Issue: Karaoke Mugen Fails to Connect to Server | Output err from pg_ctl : pg_ctl: no server running

Hi team,

I apologize for bringing up this issue again, as it was mentioned before on Discord, which I believe was concluded with no solution but for me to use my workaround of using CloudFlare Warp as a fix. However, as it still hasn’t been resolved on my computer, I wanted to bring it up here for anyone who hasn’t read it on Discord, BUT for the record, as I mentioned in my concluding remarks, I know this isn’t a really high priority issue and I am content to use my workaround for as long as it takes to be solved. Also I apologise in advance for the essay that’s coming up but I’m just trying to give as much detail as possible. Thanks in advance! :pray:

Issue Details:

Whenever I launch Karaoke Mugen, it fails to connect to the server. Here are some important points to consider:

  • My DNS was (and currently) always set to Cloudflare’s 1.1.1.1 system-wide. While I can fall back to my ISP’s assigned DNS values, I’d prefer keeping a public DNS 1.1.1.1 or 8.8.8.8 for general security and privacy.
  • I haven’t changed any modem settings.
  • Despite these settings, there’s still a connection issue, which could theoretically affect operations (although I haven’t been brave enough to try submitting any songs with the error that pops up “[NOTIFICATION.OPERATOR.ERROR.STATS.PAYLOAD]”).

Temporary Solution:

The only solution that works for me (after some troubleshooting) right now is using Cloudflare’s Warp service (for some reason), which is essentially a VPN. Interestingly, other VPNs like ProtonVPN do not fix this issue; they just replicate the problem I encounter without any VPN. :globe_with_meridians:

Attachments:

I’ve attached three folders for reference:

  1. Normal
    This folder contains all the logs produced when I open the app with my normal (no VPN) connection, which works perfectly fine for every other app on my PC. Since it had been a while since I opened KM, the log is a bit big… but I was able to update successfully, even without Cloudflare’s Warp. Additionally, there are screenshots showing that Karaoke Mugen is not on the firewall watch list and has been allowed to run on the computer.

  2. Warp
    This folder contains the log files (that chronologically occurred after “1-Normal log files”) produced after I connect to Cloudflare’s Warp, resulting in a successful connection with no errors. With this configuration, in the past I’ve successfully uploaded a few songs.
    Note: in the karaokemugen log, this starts at line 7166 at “{“level”:“warn”,“message”:“SECURITY CODE : 676946”,“service”:“Auth”,“timestamp”:“2024-07-02T11:03:57.520Z”}”

  3. Retrial
    This folder shows the log files chronologically after the successful warp connection. This is mainly to highlight what went wrong that this issue is repeatable.
    Note: in the karaokemugen log, this starts at line 7295 at {“level”:“warn”,“message”:“SECURITY CODE : 460857”,“service”:“Auth”,“timestamp”:“2024-07-02T11:25:27.609Z”}

Additional Information:

  • I’ve already tried deleting my old PostgreSQL folder and regenerating it based on advice from a previous post, but this didn’t help. :card_index_dividers:

Normally I’m not really nit-picky when it comes to using apps but since this is the only app on my system that doesn’t work without another service being activated and there is previous evidence that shows that it had worked before without Warp, its just a little fretful. Additionally I wouldn’t like to leave Cloudflare Warp connected on my computer the whole time due to security concerns as some of the traffic is routed through China and certain websites that use my location see me connected in another country. :earth_africa:

As I might be the only one experiencing this issue I woudnt mind if there’s a way to completely uninstall and reset Karaoke Mugen (and if needed Git as well) to start from scratch and see if that helps. :arrows_counterclockwise:

Even if this issue is unique to my system and not the app’s fault, I’d like to find a solution. Again, I understand this might not be a high-priority issue, especially since no one else has reported it, in which case, I’m content to continue using Cloudflare Warp as a workaround for as long as it takes. Also as always if anything else is needed for me to provide more information on this issue I’m more than happy to do that however my response time might be a bit slow because it’s no longer on Discord thus I no longer get notified if anyone has responded.

Link to folders:
GDrive

Thank you so much for your attention and help!

Best regards,
Royce :blush:

Sorry for taking some time to respond, and welcome to the forums :slight_smile:

First a few things as I think you’re mixing a few things here.

  • I don’t see any attached folder or logs for reference. Maybe you forgot to add them ?
  • Connection to postgres is completely independent from the internet as it’s a postgres server on your machine. So I don’t see what it has to do with anything.
  • DNS has nothing to do with your ability to reach a server or not. It’s just used to translate server names into IP addresses.
  • If I remember correctly you’re experiencing timeouts. It’d be interesting to see if you can ping kara.moe and also do a tracert kara.moe in your terminal to see the output and see where it’s failing to reach the server.
  • When you can, give me your IP address in private on Discord for example (go to https://whatismyip.com to get it) I’ll check if there isn’t some weird firewall rule on our end.

Now if you want to completely remove Karaoke Mugen and start over, you can simply remove it from Windows like you would do with any other app, and remove C:\user\myuser\KaraokeMugen completely. Then do a reinstall.

But I don’t think that’ll change anything.

Hi Axel,

Thanks for getting back to me and for the warm welcome! :blush:

I apologize for the confusion and for not highlighting where the folders and logs in my previous message were attached. I am using a google drive link as I can’t upload zip files here. I’ll upload a copy of everything to discord as well just in case.

https://drive.google.com/drive/folders/1Ps3bXT6rQDe3jqVjhf9BhjNKNudMWHep?usp=sharing

Here are the details you requested:

  1. Ping and Tracert Results:

    • I pinged kara.moe and here are the results:

    Ping Results without WARP

    C:\Users\royce>ping kara.moe
    Pinging kara.moe [54.36.176.153] with 32 bytes of data:
    Reply from 54.36.176.153: bytes=32 time=302ms TTL=44
    Reply from 54.36.176.153: bytes=32 time=301ms TTL=44
    Reply from 54.36.176.153: bytes=32 time=302ms TTL=44
    Reply from 54.36.176.153: bytes=32 time=302ms TTL=44
    
    Ping statistics for 54.36.176.153:
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 301ms, Maximum = 302ms, Average = 301ms
    

    Ping Results with WARP

    C:\Users\royce>ping kara.moe
    
    Pinging kara.moe [2001:41d0:303:4699::] with 32 bytes of data:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    
    Ping statistics for 2001:41d0:303:4699:::
        Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    

    This was a bit bizarre for me as I was still able to load kara.moe on the browser and was previously able to upload songs using the Karaoke Mugen application successfully with WARP enabled.

    • I also did a tracert for kara.moe and here are the results:

    TraceRoute Results without WARP

    Tracing route to kara.moe [54.36.176.153]
    over a maximum of 30 hops:
    
      1    <1 ms    <1 ms    <1 ms  192.168.20.1
      2    10 ms    10 ms    10 ms  lo0-30.bng51.alexeqn.nsw.vocus.network [203.134.4.29]
      3    11 ms    10 ms    13 ms  90.2.134.203.core.vocus.network [203.134.2.90]
      4     *        *        *     Request timed out.
      5     *        *        *     Request timed out.
      6   170 ms   169 ms   170 ms  be202.bdr03.sjc01.ca.us.vocus.network [114.31.199.43]
      7   170 ms   170 ms   170 ms  be101.bdr03.lax01.ca.us.vocus.network [114.31.199.35]
      8   173 ms   172 ms   176 ms  ovh.as16276.any2ix.coresite.com [206.72.210.214]
      9     *        *        *     Request timed out.
     10     *        *        *     Request timed out.
     11     *        *        *     Request timed out.
     12   227 ms   227 ms   230 ms  was-nva1-sbb1-nc5.va.us [178.32.135.161]
     13     *        *        *     Request timed out.
     14   306 ms   299 ms   300 ms  be104.lon-drch-sbb1-nc5.uk.eu [192.99.146.132]
     15   305 ms   307 ms   305 ms  be103.gra-g2-nc5.fr.eu [213.251.128.64]
     16     *        *        *     Request timed out.
     17     *        *        *     Request timed out.
     18     *        *        *     Request timed out.
     19     *        *        *     Request timed out.
     20   303 ms   305 ms   302 ms  erin.mahoro-net.org [54.36.176.153]
    
    Trace complete.
    

    TraceRoute Results with WARP

     C:\Users\royce>tracert kara.moe
     
     Tracing route to kara.moe [2001:41d0:303:4699::]
     over a maximum of 30 hops:
    
       1     *        *        *     Request timed out.
       2     *        *        *     Request timed out.
       3     *        *        *     Request timed out.
       4     *        *        *     Request timed out.
       5     *        *        *     Request timed out.
       6     *        *        *     Request timed out.
       7     *        *        *     Request timed out.
       8     *        *        *     Request timed out.
       9     *        *        *     Request timed out.
      10     *        *        *     Request timed out.
      11     *        *        *     Request timed out.
      12     *        *        *     Request timed out.
      13     *        *        *     Request timed out.
      14     *        *        *     Request timed out.
      15     *        *        *     Request timed out.
      16     *        *        *     Request timed out.
      17     *        *        *     Request timed out.
      18     *        *        *     Request timed out.
      19     *        *        *     Request timed out.
      20     *        *        *     Request timed out.
      21     *        *        *     Request timed out.
      22     *        *        *     Request timed out.
      23     *        *        *     Request timed out.
      24     *        *        *     Request timed out.
      25     *        *        *     Request timed out.
      26     *        *        *     Request timed out.
      27     *        *        *     Request timed out.
      28     *        *        *     Request timed out.
      29     *        *        *     Request timed out.
      30     *        *        *     Request timed out.
     
     Trace complete.
    

This was also bizarre as while this was running the Karaoke Mugen application was able to successfully update and send the payload to kara.moe.

  1. IP Address:
  • I will also send my IP address as well to you in private on Discord as suggested. Thank you for offering to check for any weird firewall rules on your end.

Regarding the DNS"

  • I mentioned DNS because changing to Cloudflare’s Warp (which I believe handles DNS differently) seemed to resolve the connection issue. I wanted to cover all potential factors, but I appreciate the clarification.

Lastly, thanks for the instructions on completely removing and reinstalling Karaoke Mugen, but as advised I wont do that. I also have noticed that there’s been a recent significant update to the application regarding the Data Storage requirements so I have performed the updates to see if anything has changed regarding this issue, and to me it appears it is still prevalent. It will be uploaded into a folder under 8 Jul 24. If it matters, the first time I opened Karaoke Mugen today was with WARP enabled, then after successfully updating, with WARP disabled to see if anything had changed.
Note: WARP was disabled on line 3383 in the 8 Jul Folder at “{“level”:“info”,“message”:“Closing”,“service”:“Engine”,“timestamp”:“2024-07-08T09:13:32.805Z”}”

Thank you again for your assistance! I really do appreciate you spending time on this however I’d like to reiterate that it’s not really a major issue if I’m the only one experiencing it. Hopefully it’s a simple fix such as whitelisting my IP or something similar. Looking forward to your response.

Best regards,
Royce

So, just to make sure. Without warp it works, but with it enabled it doesn’t.

From the trace I see the problem : Warp uses its own DNS and it resolves Kara.moe to its ipv6 address. However your ISP doesn’t seem to support ipv6 at all.

You should ask them to enable it if they support it, and if not, disable the ipv6 stack on your network connection on windows so it only uses ipv4.

This explains why it mysteriously timeouts on Kara.moe.

actually, I believe it’s the other way around… Karaoke Mugen encounters issues when WARP is not running, and only works if WARP is running. I have tried to prioritise IPv4 by setting IPv6 to obtain DNS servers automatically. I’ve also tried to disable IPv6 as a ethernet property to no avail.

edit: update. turns out it was an ISP issue. after calling my provider i changed a couple settings including using the default gateway for IPv6 and believe this fixed the issue.